Thursday, November 06, 2008

error log, enable tty console

errlogter (test the errpt)
/usr/lib/errdemon (errpt demon)
alog -o -t console (show console message)

smitty tty

Friday, October 24, 2008

check memory info. in AIX

# bootinfo -r

# svmon -G (use 4K block to count)
size inuse free pin virtual
memory 1048576 584861 463715 82089 532513
pg space 425984 409635

work pers clnt lpage
pin 82089 0 0 0
in use 289507 295354 0 0

Thursday, October 09, 2008

Unlock root account in HP-UX

From
How to unlock locked root account in HP-UX

By default HP-UX disables the root account if there is repeated number of failed (bad password) attempts. If you root account has been disabled because of bad password there are two options you two ways you can unlock the account without rebooting the server.

1.If you have sudo installed and your account is setup with root privileges then you can login as sudo su and then you can unlock the account using modprpw

$/usr/local/bin/sudo su –

##/usr/lbin/modprpw –l –k root


2.If you don't have sudo setup then other way out is to check on GSP console if you already have root logged in then you can re-enable root account from GSP console

Thursday, August 21, 2008

About Tape Drive in Solaris

New install:
devfsadm

Already installed
modinfo //find the 'st' driver.
modunload -i //The driver should unload.
mt -f /dev/rmt/0cbn status //The driver should reload.

Tuesday, April 01, 2008

nice command

kill process from "ps -ef"
ps -ef grep -v grep grep [process_name] awk '{print $2}' xargs -t kill -9 >> $outfile 2>&1

Thursday, February 14, 2008

Sybase RPC between different servers

local server: A
remote server: B

1. login to A
2. add server B records at A's interfaces file
3. isql to A's Sybase
4. sp_addserver [server name],[remote server network name (e.g. same as interfaces file)]
  • sp_addserver B,B
  • go
5. create proxy table [table_name] at "[server.db.dbo.table]"
  • use master
  • go

  • create proxy_table proxy_tb_a at "B.db_a.dbo.tb_a"
  • go

  • insert into proxy_tb_a values(....)
  • go

Monday, February 04, 2008

solaris 5.8 notes 3

large file maintenance:
cp large.log large.log.20080204.bak
cat /dev/null > large.log